/jira/ - Migliorie e supporto

Nome
Email
Oggetto
Commento
File
Password (Per rimozione del file)
Limiti: Caratteri: 5400
Numero massimo file: 6
Upload massimo supportato: 10MB

Vai in fondo ] [ Torna ] [ Catalogo ]  — 


File: 1607935792709.jpg (115.98 KB, 650x919, 8fef4b89-b07b-4ad0-a8a1-7b….jpg)

 No.79

ho aperto un thread su /b/, sono uscito dal sito. Ho riaperto /b/ poco dopo (roba di un minuto, forse due) dopo per lasciarlo aperto e non c'era il thread. Sono andato sul catalogo e il thread c'era.
Ho refreshato con ctrl+f5 e il thread è apparso su /b/
Immagino dipenda dal fatto che la pagina venga fatta cacheare dal browser. Non so se è voluto o meno, ma segnalo.
Ciao.

 No.80

Devo indagare sulle logiche di caching sia del monolite php che di cloudflare. Come ogni altra cosa, risolverò anche questa, non preoccuparti

 No.91

fatto

 No.92

c'è ancora il problema

 No.93

>>92
anzi è peggiorato molto
non si aggiorna il singolo thread da qalsiasi board, let alone dall indice

poi è lentissimo

perchè? inb4 è una psyop del fragolaccio

 No.94

>>91
>>92
Scusate ma dubito che sia la verità

Soprattutto perché
>>92 è un post pretenzioso e ancora di più perché è l'unico post con quell'IP.
Ho disattivato la cache per index e thread, oltre a non essere presente alcun caching per gli html su cloudflare.

Aspetto segnalazioni di altri ananananani, in quel caso l'ultima cosa da prendere in considerazione è che la macchina non riesca a riscrivere abbastanza in fretta gli html prima del vostro refresh(e quindi ci vuole un upgrade della macchina stessa) ma è altamente improbabile.

Attendo.

 No.95

File: 1608396115842.jpg (124.21 KB, 1200x685, bowsette-1.jpg)

>>94
>92 (Tu) è un post pretenzioso e ancora di più perché è l'unico post con quell'IP.
anon.. dovresti ormai sapere che cambio ip ogni microsecondo e non è nemmeno colpa mia

>Ho disattivato la cache per index e thread, oltre a non essere presente alcun caching per gli html su cloudflare.

adesso funziona perfettamente, direi che il problema è risolto!

 No.96

>>95
ho appena provato a tornare sul sito e.. il problema c'è ancora!

devo premere F5.

non c'è un modo per forzare il browser/CF a mandare sempre la versione aggiornata?
alla ifne il web funziona così, il caching non ha senso.
se non vuoi traffico ad cazzum puoi mettere il caricamento delle immagini in modalità lazy, c'è un tag apposito.

 No.97

>>96
Fammi un esempio di cosa accade esattamente, tipo:

- scrivo un post, ma dopo averlo postato il thread non mostra ancora il nuovo post


Oppure


- scrivo un post e lo vedo nel thread ma se torno nell'index della board allora il post nuovo non si vede ancora fino a quando non faccio F5


Devi sapere che ad ogni post viene "riscritto" l'html che viene servito, quindi l'unica cosa che mi viene in mente è che la macchina non fa in tempo a riscrivere l'html prima che tu lo ricarichi.

 No.98

Sono sempre io, gioco 100 goleador che quello che ti succede è che quando torni all'index della board non vedi l'ultimo post nel thread vero?

Se è cosi,ho capito il problema.

 No.111

Ma quindi questo problema c'è ancora o no?
Ho rilasciato oggi una versione che tecnicamente dovrebbe implementare la mia ultima opzione contro il problema

 No.123

>>97
Non sono lui.
Scrivo un post e lo vedo nel thread ma se vado su altre board e poi ritorno dov'ero prima allora il post nuovo non si vede ancora fino a quando non faccio F5.

 No.124

>>123
Se premi "indietro" col browser è diverso, non è un problema del sito. Il browser ti ripropone esattamente ciò ce c'era prima senza fare alcuna chiamata, quando premi indietro.

 No.126

>>124
Non succede con "indietro", succede navigando con la barra.
Comunque non credo sia un problema del sito, almeno che non lo sia direttamente, magari serve qualcosa per forzare il caricamento delle pagine.

 No.127

File: 1609603785032.png (16.58 KB, 460x460, ClipboardImage.png)

devi levare il caching non solo dai file HTML ma pure dai file JSON della 4chan API poiché sono quelli che vengono usati dai vari script JS, aslutti

 No.128

>>127
Grazie anano, ci darò uno sguardo nei prossimi giorni, dalla prossima settimana riprendo le migliorie, mi son dato un po' di ferie

 No.140

>>127
Beh ho seguito il tuo consiglio, speriamo che ora funzioni bene.

 No.153

>>140
ci sono ancora problemi con la cache o è finalmente tutto risolto?

 No.181

ho appena aperto un thread su /b/ e il problema si è ripresentato:
>apro thread
>vengo redirezionato al thread
>chiudo scheda
>vado a farmi un giro su internet
>torno per vedere se qualcuno ha risposto
>il thread non c'è
>mi ricordo che c'era il bug e avevo segnalato su jira
>premo ctrl+f5 e il thread appare

Forse è perché uso firefox?

 No.182

>>181
No, devo seguire l'ultimo consiglio postato e implementarlo, ci vuole poco ma non ho avuto energie in questa settimana. Verrà fixato

 No.186

Ho finalmente fixato.

Stavolta per davvero.



[Post a Reply]
Elimina post [ ]

[Nuova risposta]
Vai in cima ] [ Torna ] [ Catalogo ]